Metin Biçiminde olan sayılar

Makalenin detay bilgilerini görebilmek için kayıt olmalı ya da giriş yapmalısınız.

Ekleyen Eklenme Tarihi Güncelleme Tarihi

EXCEL DEPO Doğrulanmış Kullanıcı Vip Üye

28 Şubat 2019

04 Nisan 2020

Bu makale Excel’de Metin Biçiminde Olan Sayılar hakkında bilgi vermektedir.
Bu makale Excel’de Metin Biçiminde Olan Sayılar hakkında bilgi vermek ve gerekmesi halinde nasıl düzeltileceğini öğretmek amacıyla hazırlanmıştır.

Excel, gelişmiş özelliklerine bağlı olarak, iş dünyasında kullanılan tüm programlara veri aktarma ve aynı programlara veri sağlama özelliğini sağlayan çok güçlü bir yazılımdır.
Kullanılan özel programların büyük bir çoğunluğu, oluşturulan raporların Excel'e aktarılmasını sağlar.
Excel gibi güçlü bir yazılım varken, sanırım kimse daha gelişmiş bir raporlama aracı tasarlamak ile uğraşmak istemez.

Ama bazı durumlarda, bu programlardan Excel'e aktarılan veriler, istediğimiz biçimlerde gelmezler (ben iş bilmez yazılımcılardan kaynaklandığını düşünüyorum) ve müdahale etmemiz gerekebilir.
Bu makalemizin konusunu da, bu tür hatalı biçimde gelen sayılarla nasıl işlem yapılacağı oluşturmaktadır.

Excel'e X bir programdan veri aktarımı yaptım ve aşağıdaki gibi bir sonuç aldım:

Metin Biçimi
Eğer aktarım sonrasında, Excel sayfanızdaki sayılar, üst resimde ok ile işaretlediğim alandaki gibiyse, Excel bu sayıları ne yazık ki Metin (Text) biçiminde görmektedir.
Metin biçimindeki sayılarınızla, hiç bir şekilde matematiksel işlem (toplama, çıkarma, çarpma, bölme vs) yapamazsınız.
Peki bu tür işlemleri yapabilmek için ne yapmanız gerekir?

İlk olarak; bu sayıları aşağıdaki resimde göreceğiniz şekilde Sayı (Number) biçimine dönüştürebilirsiz. Bu yöntem en garanti olup, ilk önereceğim yöntemdir.

Metin Biçimindeki Sayılar
Peki alternatif olarak neler yapabiliriz?

Önce, boş bir Excel hücresine 1 yazıyoruz ve 1 rakamını yazdığımız hücreyi Ctrl + C tuşuna basarak kopyalıyoruz.

Metin Biçimindeki Sayılar
Hücrenin kopyalanmış olduğundan emin olmamız gerekir (etrafındaki kesik çizgilerin olduğundan emin olun)

Daha sonra, sayılarımızın olduğu alanı seçiyoruz.

Metin Biçimi Seçim
Üstte görüleceği üzere 1 rakamının olduğu hücre yapıştırmaya hazır modda.

3. adımda, alan seçiliyken farenin sağ tuşuna basıyoruz ve Özel Yapıştır seçeneklerini seçiyoruz.

Özel Yapıştır
Özel Yapıştır'ı tıkladıktan sonra karşımıza çıkacak olan aşağıdaki resimde görüleceği seçenekleri işaretleyip, tamam dedikten sonra artık Metin biçimindeki sayılarımız, işlem yapabileceğimiz şekilde Sayı biçimine dönüşmüş oldu.

Özel Yapıştır - Çarp
Son olarak bu işlemlerle uğraşmadan, formül oluşturarak bu sayıları toplamak isterseniz;
=TOPLA.ÇARPIM((B5:B13<>"")*(B5:B13)) formülünü yazmanız yeterli olacaktır.

Excel’de Metin Biçiminde Olan Sayılar hakkında fikir sahibi olduğunuzu varsayarak, yararlı olması temenni ederiz..

Bu tür sayıların nasıl toplanacağını öğrenmek için Metin Biçiminde Olan Sayıları Toplama isimli videomuzu izleyebilirsiniz.

BU MAKALEDE KULLANILAN EXCEL ÖZELLİKLERİ:

TOPLA.ÇARPIM - PasteSpecial


ETİKETLER:

#excel #metin #biçimindeki #sayı #ondalık #dönüştürme


Önceki Makale Sonraki Makale